雑記
シャドバのバックアップ

iPhoneの調子が悪いので初期化してみた。
ゲームアプリの引継ぎもいちおう万全のはず…(ここまで前記事のコピペ)

今度はシャドバの引き継ぎができない(Shadowverse)。
なんでや!と思ったら引き継ぎの仕様が知らない間に変わってた。
パスワード設定してないやん!!諦めるしかないのか!!

いや待てPC版で設定すればいいやん!!
ってことでDMM GAMESでデータ連携してたのでそっちからパスワード設定して引き継ぎ。
はーよかった。
LinksMateでゲーム連携してたので報酬が無駄になるかと思った。
念のためFacebookとGameCenterでアカウント連携も済ましておいた。
GameCenterってなんなのかよくわかってないけど…。

ところでiPhoneで見たらLinksMateのゲーム連携特典が来てないので、
なんでだろうと思ったら、iOS版じゃ受け取れないのね。グラブルと一緒か。
グラブルはモバゲ版使えばいいけどシャドバは別端末にしないとだから面倒ね。

エムステのバックアップ

iPhoneの調子が悪いので初期化してみた。
ゲームアプリの引継ぎもいちおう万全のはず…

と思ったらエムステで引継ぎができない。(アイドルマスターSideM LIVE ON ST@GE!のこと)
「同じ端末でのデータ引き継ぎはできません」
えっ!!バックアップの意味ないじゃん!!

アプリの再インストールをしないと引き継ぎできないのでした。
iTunesのバックアップで復元するとアプリ(と一部アプリのログイン状況)も復元されるんだけど、それだとインストールしたままと認識されるみたい。
インストールしたままだからってデータ引き継ぎできないのおかしいと思うんだけど…。

うんこのかきかた

そこそこ固めな一本糞を描くときは、
極小粒納豆を固めたイメージで描くと、
色も見た目もいい感じになりそう。

PowerMateがスタートアップ起動しない問題

にせぞーは左手デバイスにPowerMateというのを使ってます。


Griffin Technology PowerMate 【カスタマイズ可能なUSBマルチメディアコントローラー (スペースグレー)

こういうダイアル式のやつですね。
ただこれ、Vistaまででドライバの更新が途絶えています。

それでもまあ問題なく使っていたんですが、ある時スタートアップしてないことに気付きました。
Windows 10にしてからでしょうか。
とくに気にもせず使ってたんですが、ふと気が付いたので直そうとしてみることに。
スタートアップ自体はプロパティから互換性のトラブルシューティングでXPSP3の互換モードにすることで直りました。
VistaSP2までのやつならどれでもいいと思います。

ただそこにたどり着くまで四苦八苦している間になぜかUACの対象になってしまったようで、
起動すると「不明な発行元からのアプリがデバイスに変更を加えることを許可しますか?」とかいうダイアログが出てしまうように。
するとせっかくスタートアップにしたのにいちいち「はい」を押さないと起動しない。
もともと起動するときにそんなの出てなかったのに。
いつのまにかアイコンの右下にUACの盾マークがついてるし。
とりあえずらちが明かないのでUACを無効にして解決。
本当はUAC無効はやりたくなかったんですがいっこうに解決策が見つからないので妥協。

互換性にたどり着くまでに、
タスクスケジューラを使ってみたり管理者として実行する設定にしたりしてみたせいかしら…。
あるいは一度アンインストールして入れ直してみたからか…。
スッキリしない感じ。

ページナビゲーションのやつ解決

フロントページ以外の個別ページ(固定ページpage.php除く)にページナビゲーションを手動で入れてます。
Preview Nextってやつ。
それを右カラムに入れてるんですけど、
左カラムがこのページナビゲーションの高さ分下がってしまう問題がありました。

左サイドバー上に余計なpaddingができる問題
http://nisezo.com/archives/4850

またレイアウトが崩れている
http://nisezo.com/archives/5119

で、それがfloatで左右割り付けしてるせいだというのはわかっていたので、
table-cellにして解決。
ついでにspanだったやつをdivにした。
インライン要素よりブロック要素の方が好きなので。
HTMLやCSSについてよくわかってないのがバレバレな発言ですけど。
み、見えればいいんだ見えれば。

これを↓

div.pagenav {
font-size: 90%;
}

span.pageprev {
float: left;
margin: 10px 0px 20px 25px;
}

span.pagenext {
float: right;
margin: 10px 25px 20px 0px;
}

こう↓

div.pagenav {
width: 95%;
font-size: 90%;
display: table;
margin: auto;
padding-bottom: 20px;
}

div.pageprev {
width: 50%;
display: table-cell;
text-align: left;
}

div.pagenext {
width: 50%;
display: table-cell;
text-align: right;
}

ただこのためにspanをdivに変えてみたわけですけど、
そしたら変えたページだけページ全体の上に謎の空白ができている。
まず最初にやってみたsingle.phpでできてしまった。
front-page.phpと同じ現象なので、phpをいじるとこうなるというのは確定。
…で、どこが変わってるんだろ…そんなとこいじってないはずなんだけど…。

WordPressのテーマ編集からソース全選択でコピペしたやつをいじってるので、
それがわるいのかと思って、とりあえずFTPでDLしたcategory.phpをそのままULしてみる。
これは上に空白出来ず変わらず。
じゃあそれをsingle.phpみたいにspanからdivにいじってULすると…?
これも変わらない!
じゃあsingle.phpのcategory.phpと違う部分だけをcategory.phpにコピペしてそれをsingle.phpとしてUPすると…?
single.phpの上の空白が消えた。
とりあえずテーマ編集からコピペしてそれをいじったやつをULすると空白ができてしまうみたい。
いったいなにが違うんだ…。
とりあえずfront-pageもbody部分をsingle.phpにコピペしたもので上書きして修正。

あとnext_posts_linkが空参照してしまうやつを見つけたのでそれもどうにかならんかな…

WordPressにうまくpngをアップできない問題

今しがたコミティア124の参加情報を投稿しました。
で、サークルカットがpngだとうまくWordpressでアップできない。
こういった現象ははちょいちょい出くわしてそのたびに困ってます。
png画像が一律でダメなわけでなく、たぶんクリスタで作ったやつだけ。
前はなんか解決してた気がするけど忘れちゃった。

どういう感じかというと、pngだとこうなる。

jpgだとこう。本来はpngもこうなってほしい。

ペイントとか他のソフトで開いてから上書き保存することで以前は解決してた気がしたんだけど、
今回やってみたらとくに意味なし。透明度情報が悪いわけでもないみたい。
clipをpsdにしてフォトショやSAIでpng化してみても意味なし。
Wordpressを経由せずにFTPとかでアップしてみたら多分いいと思うんだけど、
Wordpressのメディアライブラリには入ってほしいし。

あとこの記事アップして気付いたけどこの記事の画像の表示サイズが合ってない。
widthとheightを指定してあるのに全然効いてない。めっちゃ拡大されてる。
これもなんか解決策あった気がするけど忘れた。

あとfront-pageのLightboxの挙動がおかしい。
基準点が画面より下に行くし画像サイズがウィンドウサイズの高さを反映しない。
めちゃめちゃ。

そんなわけでメモ。解決策が見つかれば追記する。

(追記)
ページナビゲーションとか上の空白とか修正してたらいつのまにかLightboxの挙動が正しくなった…。
とりあえずあとは画像サイズとpngか…。

(追記)
画像サイズのwidthが効かないのはwidth:100%とmin-width:400pxが原因。
max-widthのつもりで入れてた…。そりゃ意地でも400pxになるわ…。
上記二つを消してmax-width:100%にして解決。
あとはpng問題か…これはサイトデザインじゃなくてWordpressの問題だから難しそう。